Our support is available from: Monday - Friday | 8:00 AM - 5:30 PM GMT+7

Our Time:
Update Puca v1.5

To Puca v1.5 works correctly, we recommend:

- Required "Tbay framework pro" version 1.2 or greater

- Required "WooCommerce" version 3.6 or greater